doit
Posts: 3
Joined: Tue Aug 18, 2015 3:25 am

Remote TCP debug Tools

Tue Aug 18, 2015 3:30 am

step A:
Obtain the ip and port via http://tcp.doit.am
for example:
ip=115.29.109.104
port=6556
step B:
How to use :
Step 1:
The client connects 115.29.109.104 and 6556, for example: telnet 115.29.109.104 6556
Step 2:
The another connects 115.29.109.104 and 6556,for example: telnet 115.29.109.104 6556
Step 3:
Data is transmitted between the two clients.

Murielsiny
Posts: 1
Joined: Mon Jan 11, 2016 11:22 am

Remote TCP debug Tools

Thu Jan 14, 2016 5:07 am

Get The Same Users And Passwords On Both Computers

Have Client Go to Solutions Explorer > Properties > Debug > "Use remote machine" and input the IPADDRESS

then go to

"Tools" > Project and Solutions > check "Show Advance Build Options"

Compile > Advanced Compile Options > Make Sure Define DEBUG constant is checks to see Remote Debug Messages

If on the remote Machine you dont Include your PBD file locally you will get a warning due to System Variables

Users of VS for remote debugging may have found themselves blocked on RC2 builds. Msvsmon.exe will run but claim it has to set up the firewall and then it errors out for all the available options. This is a result of by design change in Vista to tighten firewall security. The workaround is to manually enable the firewall settings from an elevated command prompt using this set of commands:



netsh advfirewall firewall add rule name="Microsoft Visual Studio Remote Debugger - UDP 137" dir=in action=allow enable=yes localport=137 protocol=udp



netsh advfirewall firewall add rule name="Microsoft Visual Studio Remote Debugger - UDP 138" dir=in action=allow enable=yes localport=138 protocol=udp



netsh advfirewall firewall add rule name="Microsoft Visual Studio Remote Debugger - TCP 139" dir=in action=allow enable=yes localport=139 protocol=tcp



netsh advfirewall firewall add rule name="Microsoft Visual Studio Remote Debugger - TCP 445" dir=in action=allow enable=yes localport=445 protocol=tcp



When you next run msvsmon, it still prompts you to set firewall settings but this time will not error out when you give it the OK. Subsequent runs then stop asking like normal.


Return to “WiFiMCU”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest